Upgrade to Pro
— share decks privately, control downloads, hide ads and more …
Speaker Deck
Sign up for free
Menu
Search
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Pricing
Search
Sign in
Sign up for free
Knock! Knock! Who's There?
Search
Markus H
September 10, 2021
Programming
120
0
Share
Embed
Copy iframe code
Copy JS code
Copy link
Start on current slide
Knock! Knock! Who's There?
My talk from the Snakeoil Acadamy / PyCon AU 2021
Markus H
September 10, 2021
More Decks by Markus H
See All by Markus H
Oh, I Found a Security Issue (reloaded 2026)
markush
0
56
🐍 ❤️ 🦀 — Python loves Rust
markush
0
310
An Introduction To Kubernetes ☸
markush
0
160
Writing Safe Database Migrations (DjangoCon Europe 2021)
markush
0
14k
A Pony On The Move: How Migrations Work In Django 🐎
markush
0
13k
All Hands on Deck — Handling Security Issues
markush
0
14k
Logging Rethought 2: The Actions of Frank Taylor Jr. (PyCon UK 2019)
markush
0
95
Logging Rethought 2: The Actions of Frank Taylor Jr. (PyCon Australia 2019)
markush
1
250
Logging Rethought 2: The Actions of Frank Taylor Jr. (DjangoCon Europe 2019)
markush
0
13k
Other Decks in Programming
See All in Programming
複雑なUIコンポーネントとの ⻑い付き合い⽅:波及するバグからテスト戦略を経て、安全な再設計へ
mixplace
0
510
まずはコードより業務と向き合う:テーブル解体のためにPdMを呼んだ話
sakawe_ee
0
130
Optunaを作ったときにやりたかったこと、その後 (2026/10/16, Optuna Meetup #3)
iwiwi
4
1.4k
クラウドゲーミングのパフォーマンス最適化に挑む / Cloud Gaming Performance Tuning
vivion
0
320
선언형 햅틱 라이브러리 진동을 소개합니다
l2hyunwoo
1
280
自作Discord音声botをLambda MicroVMsに移行した話 / Migrating My Discord Voice Bot to Lambda MicroVMs
akihisaikeda
1
250
Getting Started with Vibe Coding
miccheng
0
180
baseline으로 마이그레이션, 리팩토링 안전하게 맡기기
fornewid
1
870
AI時代のTerminal環境を UNIX哲学で設計・運用する
yasunori0418
1
340
[JA] Domain Modeling with Vanilla Rails: 「操作」から再考するRailsの設計論
yasaichi
4
1.8k
[2026-10-14](C)Re:ゼロから始める異世界生活〜始まりの終わりと終わりの始まり〜
tosite
0
300
はじめてのPLATEAU
nokonoko1203
1
140
Featured
See All Featured
Building AI with AI
inesmontani
PRO
1
1.4k
Test your architecture with Archunit
thirion
2
2.5k
Building Better People: How to give real-time feedback that sticks.
wjessup
371
20k
What’s in a name? Adding method to the madness
productmarketing
PRO
24
4.2k
The SEO identity crisis: Don't let AI make you average
varn
0
620
The AI Search Optimization Roadmap by Aleyda Solis
aleyda
2
6.4k
Navigating Weather and Climate Data
rabernat
0
580
Navigating the moral maze — ethical principles for Al-driven product design
skipperchong
2
680
Abbi's Birthday
coloredviolet
4
11k
The untapped power of vector embeddings
frankvandijk
2
2k
Build The Right Thing And Hit Your Dates
maggiecrowley
39
3.5k
Building a Modern Day E-commerce SEO Strategy
aleyda
45
9.3k
Transcript
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Knock! Knock!
Who’s There?
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Hi, I’m
Markus Holtermann
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Hi, I’m
Markus Holtermann W e're hiring
Snakeoil Academy 2021 • PyCon AU • @m_holtermann The Beginning
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Marian Vanhaeren/Francesco
d'Errico
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Sketch by
Sydney Parkinson (1784) Portrait by Louis John Steele (1891)
Snakeoil Academy 2021 • PyCon AU • @m_holtermann
Snakeoil Academy 2021 • PyCon AU • @m_holtermann
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Snakeoil Academy
2021 • PyCon AU • @m_holtermann # scrypt >>> import base64, hashlib, secrets >>> salt = secrets.token_bytes(16) >>> password = b"my p4ssw0rd!"0 >>> hash = hashlib.scrypt(password, salt=salt, n=2**14, r=8, p=1, maxmem=0, dklen=64).hex() >>> base64.b64encode(hash).decode('ascii').strip() '8ln2EySYjOZRSLaIzjvaOaQQfGshxdH7vxptMyWo9zWJbM1glu0K8LbZf56QH+GefdiCP079IErDhVw UmPsRzQ==' # argon2 >>> from argon2 import PasswordHasher >>> hasher = PasswordHasher() >>> hasher.hash(password) '$argon2id$v=19$m=102400,t=2,p=8$d85wm2Zga0oSPiK6Uxm4zA$03Kc+n7lf3SpL+VYSbMnfA'
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Basic &
Digest Authentication RFC 2069, RFC 2617, RFC 7617
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Snakeoil Academy
2021 • PyCon AU • @m_holtermann WWW-Authenticate: Basic realm="PyConAU 2021", charset="UTF-8" Authorization: Basic Y3VybHlib2k6c25ha2VvaWwuYWNhZGVteQ== Server replies with: Client sends:
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Token Authentication
Authorization: Token soM3r4nDOmByt3s
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Bearer Authentication
RFC 6750 Authorization: Bearer eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJzdWIiOiIy MDIxIiwibmFtZSI6ImN1cmx5Ym9pIn0.W8-ixoAkGMe5Gs7c5 DLXFO0fCLypn2xhNExulY5iSEY
Snakeoil Academy 2021 • PyCon AU • @m_holtermann JWT https://groups.google.com/g/django-developers
/c/6oS9R2GwO4k/m/Rep92xfsAwAJ
Snakeoil Academy 2021 • PyCon AU • @m_holtermann JWT
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Snakeoil Academy
2021 • PyCon AU • @m_holtermann >>> import base64, json, hmac >>> key = b"snakeoil.academy" >>> data = {"uid": 123, "name": "curlyboi"} >>> payload = base64.b64encode(json.dumps(data).encode()) >>> mac = hmac.new(key, payload, digestmod="sha256") >>> payload + b"." + base64.b64encode(mac.digest()) >>> ret b'eyJ1aWQiOiAxMjMsICJuYW1lIjogImN1cmx5Ym9pIn0=.oJPUWmHZGJIXPCna082U8/SMseX+hZ5av Kjgt1TKovg=' >>> signed, signature = ret.split(b".", 1) >>> hmac.compare_digest(signature, ... base64.b64encode(hmac.new(key, signed, digestmod="sha256").digest())) True >>> json.loads(base64.b64decode(signed)) {'uid': 123, 'name': 'curlyboi'}
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Mutual Authentication
Snakeoil Academy 2021 • PyCon AU • @m_holtermann FIDO2 /
WebAuthn https://www.w3.org/TR/webauthn-2/
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Snakeoil Academy
2021 • PyCon AU • @m_holtermann
Snakeoil Academy 2021 • PyCon AU • @m_holtermann I! I
who? Identification and Authentication!
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Thank you!
Snakeoil Academy 2021 • PyCon AU • @m_holtermann Sources •
https://www.newscientist.com/article/dn9392-ancient-beads-imply-culture-older-than-we-thought/ • https://rss.onlinelibrary.wiley.com/doi/pdf/10.1111/j.1740-9713.2013.00706.x • https://www.smithsonianmag.com/history/tattoos-144038580/ • https://www.trulioo.com/blog/infographic-the-history-of-id-verification • https://github.blog/2021-04-05-behind-githubs-new-authentication-token-formats/