Upgrade to Pro
— share decks privately, control downloads, hide ads and more …
Speaker Deck
Sign up for free
Menu
Search
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Features
All features
Private URLs
Password Protection
Custom URLS
Scheduled publishing
Remove Branding
Restrict embedding
Deck Collections
Notes
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Explore
Featured decks
Featured speakers
Programming
Technology
Storyboards
Pricing
Search
Sign in
Sign up for free
PHPで学ぶ Session の基本と応用 / web-app-session-101
Search
Ryo Tomidokoro
March 20, 2021
Programming
7.2k
15
Share
Embed
Copy iframe code
Copy JS code
Copy link
Start on current slide
PHPで学ぶ Session の基本と応用 / web-app-session-101
PHPerKaigi 2021 の登壇資料です。
Cookie を使った Session 管理について解説しています。
Ryo Tomidokoro
March 20, 2021
More Decks by Ryo Tomidokoro
See All by Ryo Tomidokoro
Laravelで学ぶ Webアプリケーションチューニング入門/web_application_tuning_101
hanhan1978
4
2.6k
あるアーキテクチャ決定と その結果/architecture-decision-and-its-result
hanhan1978
2
1.9k
開発者が知っておきたい複雑さの正体/where-the-complexity-comes-from
hanhan1978
8
4k
Spec Driven Development入門/spec_driven_development_for_learners
hanhan1978
2
2k
フロントエンドがTypeScriptなら、バックエンドはPHPでもいいじゃない/php-is-not-bad
hanhan1978
8
14k
どうすると生き残れないのか/how-not-to-survive
hanhan1978
17
15k
100分で本番デプロイ!Laravelで作るWebアプリケーション作成/100min_web_app_cicd
hanhan1978
1
310
PHPerのための計算量入門/Complexity101 for PHPer
hanhan1978
8
4k
集中して作業する技術/how_to_work_deeply
hanhan1978
69
62k
Other Decks in Programming
See All in Programming
Findy - エンジニア向け会社紹介/Findy Company Deck
findyinc
6
400k
當我們開始不讀 Code - AI Agent 時代,Code Review 與 Clean Code 還剩下什麼?
jame2408
1
300
ActionController meets Protocol Buffers
sorah
0
680
PumaからFalconに移行したRailsアプリケーションでの実践
falcon8823
0
200
ChromeでローカルLLM
ryu1013
0
160
GemmaをJevのように使ってみる / Use Gemma like Jev
kishida
5
820
AIで開発が速くなった先で、開発チームは何を目指すか
shihochan
1
1.8k
Seven New Principles of Software Engineering
yegor256
0
230
RAG の “R” を Swift で覗いてみる 〜「意味から探す」検索の仕組み〜
nao_randd
0
170
自作Discord音声botをLambda MicroVMsに移行した話 / Migrating My Discord Voice Bot to Lambda MicroVMs
akihisaikeda
0
140
AWSに止められる覚悟してますか?
morizo_1984
2
540
半永久的に提供し続けられるプライベートクラウドを目指して ― 利用者の認知負荷を抑えるAPI抽象化とハードウェア世代交代の基盤設計
tomokon
0
520
Featured
See All Featured
Connecting the Dots Between Site Speed, User Experience & Your Business [WebExpo 2025]
tammyeverts
11
1.1k
Optimizing for Happiness
mojombo
378
71k
Improving Core Web Vitals using Speculation Rules API
sergeychernyshev
21
1.7k
Are puppies a ranking factor?
jonoalderson
2
4.1k
SEOcharity - Dark patterns in SEO and UX: How to avoid them and build a more ethical web
sarafernandez
0
310
Art, The Web, and Tiny UX
lynnandtonic
304
22k
Tell your own story through comics
letsgokoyo
1
1.1k
SEO for Brand Visibility & Recognition
aleyda
0
4.8k
The Illustrated Guide to Node.js - THAT Conference 2024
reverentgeek
1
580
XXLCSS - How to scale CSS and keep your sanity
sugarenia
250
1.3M
"I'm Feeling Lucky" - Building Great Search Experiences for Today's Users (#IAC19)
danielanewman
230
23k
jQuery: Nuts, Bolts and Bling
dougneiner
66
8.6k
Transcript
@hanhan1978 PHPで学ぶ Sessionの基本と応用 PHPerKaigi 2021
@hanhan1978 • 富所 亮 • 所属 ◦ 株式会社カオナビ • 職業
◦ Webアプリケーションエンジニア • ブログ ◦ https://blog.hanhans.net • Yokohama North AM ◦ https://anchor.fm/yokohama-north-am 2
今日、発表すること 3
Session 4
Webアプリケーション開発者が Session と呼んでいるものは何か? 5
Session a period of time that is spent doing a
particular activity 特定の活動に費やされた期間 https://www.oxfordlearnersdictionaries.com - Oxford Learner’s Dictionary 6
Session → この単語だけだと曖昧 7
Cookie を使った Session 管理 略して Session 8 本スライドでは以後、断りなく Session と表記した場合、
「Cookie を使った Session 管理」を表します。
今日、覚えて帰って欲しいこと 9
• 1章 「生い立ち」 • 2章 「技術的な仕組み」 • 3章 「最低限の周辺知識」 10
1章 「生い立ち」 11
Cookieから始まった 12
Cookie とは何か? どういう用途で作られた物なのか? 13
World Wide Web 1990 Nov : Tim Berners Lee 1996
May : RFC 1945 (HTTP/1.0) → ステートレスなプロトコル https://en.wikipedia.org/wiki/World_Wide_Web 14
ステートレス? 15
「Webサーバーがアプリケーション 状態を保存しない」制約 Webを支える技術 (P80) - 技術評論社 16
状態(ステート)? 17
• 何回アクセスがあった? • ログインしているか? • 前回アクセス時に何をカートに入れた 18
Webの普及に伴って 状態を持ちたいという要求が高まる 19
Cookie 1994 Oct : Mosaic Netscape (独自拡張) 1997 Feb :
RFC 2109 2000 Oct : RFC 2965 2011 Apr : RFC 6265 https://en.wikipedia.org/wiki/HTTP_cookie 20
https://tools.ietf.org/html/rfc6265 - HTTP State Management Mechanism Cookieとは ステートレスなHTTPで 状態(ステート)を持つための技術 21
22 平たく言うと
HTTPで ログインやお買い物カート を実現する技術 💴 23
24 この章のおさらい HTTPはステートレス 状態を持たせたいという欲求から Cookieが登場した
2章 「技術的な仕組」 25
まず、Cookieの仕組み 26
HTTP Response Header HTTP Request Header にCookie情報を含めて送る 27
Response Header にCookieを含める ※Webアプリケーション がセットした情報 28
HTTP Request Header 29
ブラウザとWebサーバーが 仕様に従って Cookie を送受信する と表現されると聞こえがよいが... 30
ステートレスなHTTPに 無理やりステートを入れ込んでいる 31
Cookieのデータ容量 32
一度の Req/Res で 4KBまでの データしか扱えない → Headerに載せるという前提を考えれば当然の制約 33
機微情報はHeaderで送受信したくない。 → SSL/TLSが贅沢だった時代は特に。 34
Webアプリは、状態として大量の情報をも たせてくる 例)ユーザ情報、Validation エラー、入力値、履歴...💰 35
そこで Cookieには鍵となるIDだけを保持 → Webサーバー側でデータを保存する 36
37 鍵となるID
38 初回アクセス
39 二回目以降
Cookie を使ったSession管理は分かった → プログラミング言語はどのようにサポートしているのか? 40
PHP において Session は拡張として入っ ている 41
デフォルトで有効 --disable-session で 無効にすることも可 42
(余談) どんなときに Session 拡張を無効にする? A) どうまかり間違っても Session 使ってほしくない時とか?? 43
Session 拡張無効だと、Laravel動かない 44
Session 拡張のマニュアル https://www.php.net/manual/en/ref.session.php 45
a.php name という要素を追加 b.php name要素を出力 このような無邪気なソースコー ドで、簡単に利用することが可 能 46
$_SESSION (スーパーグローバル) https://www.php.net/manual/en/reserved.variables.session.php 47
$_SESSION 直接使うのは、相当訓練されたPHPer もしくは... 48
デフォルトのSession Store ファイル /tmp/sess_[session_id] 等 余談)短時間に大量に出力すると、ほんの少しパフォーマンが落ちます 49
デフォルトの Session ID 名 PHPSESSID session.name (php.ini) session_name 関数 を使って変更可能
50
Set-Cookie で SESSION ID がセットされる 51
PHP の WAF が使う Session 実装 52
Symfony Http Foundation Component Drupal, Joomla, Laravel… 多数 53
PHP の $_SESSION, setcookie を 安全に使うためのラッパー 54
Super Global を直接いじらないで!とい う願いが込められている(多分) 55
56 この章のおさらい Session ID をキーにして状態を保存 PHPではデフォルトで利用可能 ※ただし、安全のためにもWAFの利用が推奨される
3章 「最低限の周辺知識」 57
Session 管理のセキュリティ 58
仕組の前提として Cookie が使われている 59
Cookie の正しい理解が不可欠 60
61 GoogleがセットするCookieの例
Cookieの属性 Max-Age Expires Domain Path Secure HttpOnly SameSite 属性はCase Insensitive
大文字小文字関係なし SameSiteは策定中の最新仕様だが、 すでにブラウザ側は実装済 62
特に大事な属性 63
Secure SSL/TLS通信でのみCookieを送信する 盗聴対策 64
HttpOnly JavaScriptからはアクセス不可 XSSで Cookie を盗ませない 65
WAFを使っていれば、この手のリスクは 考慮されている オレオレFWの場合や、生PHPの場合は注意が必要 66
Session 管理を狙った攻撃 67
SESSION ID さえ盗めれば 誰かになりすますことも可能 68
Session 固定化攻撃 Session ハイジャック https://www.sbcr.jp/product/4797393163/ - 安全なWebアプリケーションの作り方 第2版 69
設計されていない 不用意なSESSION利用によるバグ 70
例)保持された状態によって、本来のページ遷移がおかしくなる 71
バグの修正例 そもそも状態を持たせたことが原因なので仕様自体を見直し てSessionを使わない形にしていくと良いかも 72
Session がセキュリティのために 使われている例 73
CSRF Token 74
https://medium.com/@sachindilan/secure-software-development-synchronizer-token-pattern-9afe0cc92ba Synchronizer Token Pattern 75
Session 管理が アーキテクチャに与える影響 76
Session Store が File の場合 77
シングル構成なら問題ない 78
LoadBalancer を使うと Session Store が分散 79
対策1 共有の Session Store 80
共有 Session Store 81
対策2 Sticky Session 82
LBが空気を読んで、ユーザ毎の到達エンドポイントを固定 LBの機能なので、根本的な原因は解決されてない 83
対策3 Cookie を Session Store にする 84
非推奨(すぐに4K越えます) あなたが思うより、すぐに越えます 85
86 この章のおさらい Cookieの仕様を理解 Session 管理を狙った攻撃を把握 Session ストアを設計時に考慮
まとめ 87
1. Session という単語を正しく覚える 「Cookie を使った Session 管理」 88
2. Cookie の仕様を理解する → RFC6265 を読んでみよう https://tools.ietf.org/html/rfc6265 89
3. Session管理の仕組を理解する 90
4. Session 管理への攻撃を知る → 徳丸本読みましょう https://www.sbcr.jp/product/4797393163/ - 安全なWebアプリケーションの作り方 第2版 91
5. アーキテクチャーを意識する → Session 管理のスケーラビリティ 92
@hanhan1978 相談・指摘・その他 下記のTwitterアカウントにどうぞ 93